Expense - Performance degradation
Incident Report for Medius
Resolved
Dear users,

This incident has been resolved.

Thank you again for your patience.
Posted Nov 18, 2024 - 09:44 UTC
Investigating
Dear Users,

We are currently experiencing some slowness on both our Web and mobile Apps.
Our team is actively working on the issue, and we expect it to be temporary.

During this time, you may encounter some delays. If possible, we recommend postponing non-urgent tasks related to the Expense module.
We will keep you informed and are working quickly to resolve this issue.

Thank you for your patience.
Sincerely,
Posted Nov 18, 2024 - 08:35 UTC
This incident affected: Services (Expense).