Issue with processing incoming invoices send into Capture via email

Incident Report for Medius

Resolved

The incident has been resolved.
Posted Apr 15, 2025 - 13:19 UTC

Monitoring

The queue has been processed. All new incoming emails should be processed as usual. At the moment, we are monitoring our system.
Posted Apr 15, 2025 - 09:40 UTC

Identified

The issue was identified. One of the infrastructure components went into an unpaired state. After a restart, functionality was restored. At the moment, we are working on processing the queue of stuck emails.
Posted Apr 15, 2025 - 07:14 UTC

Investigating

We are experiencing an issue with handling incoming invoices sent to Capture via email. About half of the incoming volume is impacted. We are actively investigating the issue
Posted Apr 15, 2025 - 07:04 UTC
This incident affected: Services (Capture (Europe)).