Cloud02, 10, 20, 26 - Performance degradation

Incident Report for Medius

Resolved

This incident has been resolved.
Posted May 14, 2025 - 09:02 UTC

Monitoring

Capacity for the shared resource has been increased, we are monitor its performance
Posted May 14, 2025 - 08:15 UTC

Identified

A subset of customers on Cloud02, 10, 20, and 26 may experience degraded performance. The issue stems from a shared resource overload. Our team is working to resolve the problem and minimize its impact on users.
Posted May 14, 2025 - 07:28 UTC
This incident affected: AP Automation (Cloud02, Cloud10, Cloud20, Cloud26).